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Getting Started 

Welcome To Alert Management 

Welcome to the TalkMaster FOCUS Alert Management feature of TalkMaster FOCUS 
Automation.   

The Alert Management feature of TalkMaster FOCUS Automation* provides the ability to monitor 
RSS or CAP/ATOM feeds (i.e. from institutions such as the National Weather Service) and play the 
associated text from selected messages as notification warnings or informational audio.  The basic 
flow is as follows: 

 The Admin Console is used to specify the Queued Paging Groups and their associated IP
Endpoints that are to receive the "spoken" messages

 The Alert Management Configuration Console is used to specify the feeds and the criteria
that will be used to select the messages as well as the Queued Paging Group  to send the
audio to

 The Alert Management Service monitors the feeds and sends the selected text messages
to the TalkMaster FOCUS Server

 The TalkMaster FOCUS Server converts the text to speech and plays it to the Queued
Paging Groups

The Alert Management Service typically runs on the same machine as the TalkMaster FOCUS 
Server service. 

* TalkMaster FOCUS Automation is a separately licensed component of TalkMaster FOCUS

Release Notes 
V5.2.1 June 2016 

 Added support for the CAP 1.2 standard

V5.1 November 2015 

 Initial Release
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Alert Management Service 

Alert Management Service Configuration 

The Alert Management Service typically runs on the same machine as the TalkMaster FOCUS 
Server service.  The TalkMaster FOCUS Alert Management Service must logon to the TalkMaster 
FOCUS Server in order to communicate with it, so an Operator UserID and Password needs to be 
supplied to it as a one-time setup.   

To configure the logon information for the TalkMaster FOCUS Alert Management Service, launch 
the Alert Management Service Configuration console from the Windows Start menu All 
Programs --> TalkMaster FOCUS --> Automation --> Alert Management Service Configuration. 
This console can also be used to display the current status of the service or to restart the service. 

 Username / Password - Enter the Username and Password fields that will be used by
the TalkMaster FOCUS Alert Management Service to login to the TalkMaster FOCUS
Server.  They must be defined in the Admin Console under the Operators tab

 IP Address - Enter the IP Address is the address of the TalkMaster FOCUS Server and the
associated Console Port as defined in the Admin Console.  The Console Port defaults to
3010

 Debug Tracking - This should be left unchecked unless instructed by Digital Acoustics
Technical Support

 Server Status - The Service Status area will display the current connection status of the
service

Save - Once the above changes have been made, press this button to apply the changes: 
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 If the Server Status indicates that the Alert Management Service is running, but not connected
to the TalkMaster FOCUS Server, it will try to logon immediately and the Server Status should
change to Connected to iEnterprise

 If the Server Status indicates that the Alert Management Service is not running, then select
menu option Tools --> Restart Service to connect with the updated information

OK - Press this button to save the changes and exit 

Cancel - Press this button to ignore the unsaved changes and exit 

Alert Management Service Configuration Menu 

File->Exit - Exits and saves the configuration information 

Tools->Restart Service - Restarts the Alert Management Service 
Tools->Open Support Folder - Opens the support folder where the Debug Tracking Log is stored 

Help->About -  Displays the version information for the Alert Management Service Configuration 
console 
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Alert Management Configuration Console 

Alert Management Configuration Console Overview 

The Alert Management Configuration Console is used to setup feeds so them can be processed 
by the Alert Management Service.  The configuration console can work with two types of feeds: 
RSS and CAP/ATOM.  RSS is typically used for news feeds that discuss various topics and are 
available from media outlets such as Fox News, ESPN, and others.  CAP/ATOM are feeds that are 
published for alerting needs from organizations such as National Oceanic and Atmospheric 
Administration (NOAA), U.S. Geological Survey (USGS), etc.  Customer's can also create their own 
RSS or CAP/ATOM feeds in order to create automated audio alerts. 

Once the feeds have been setup, the Alert Management Service monitors them to select the 
messages that will be converted to speech and played on a group of IP7 Endpoints. 

Alert Management Configuration Logon 
To start the Alert Management Configuration Console, open the Windows Start menu --> All Programs 
--> TalkMaster FOCUS --> Automation --> Alert Management Configuration.  The following Logon 
dialog will be presented:  

 Logon ID - Enter the Logon ID as configured in the Admin Console --> Operators tab

 Password -  Enter the associated password for the Logon ID

 Address - Enter the IP Address and port of the TalkMaster FOCUS Server.

In the Admin Console on the Operators tab, check the Allow Multiple Logons checkbox for the 
Operator ID that is used for administering TalkMaster instead of creating a separate UserID for each 
configuration application 

Application Layout 

The Alert Management Configuration Console screen lists the Feeds that have been defined. 
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 Feed Title - The name of the Feed is automatically provided from the feed

 Status - The status will be listed as Available or Unavailable. Unavailable means that the
URL cannot be contacted

 Last Access - Displays the last date and time since the Configuration Console was open that
the Alert was activated

 By right-clicking on a feed, the Last Access date and time can be reset.  If the Alert
has not expired, it will be played again

Creating a CAP/ATOM Feed 

Below is an example of how to setup a CAP/Atom feed. 

 Open a web browser  to http://alerts.weather.gov/

 Scroll down the page, find Illinois from the list of states, then select County List

 Select the Atom icon on the left side of the page for "DuPage"

Creating an RSS Feed

 The XML for the page is displayed

 Copy the URL using the keyboard shortcut CTRL-C

 Open and login to the the Alert Management Configuration Console

 Click the NEW button

 Using the keyboard shortcut CTRL-V, paste the URL into the CAP/RSS Feed URL shown
below

http://alerts.weather.gov/
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 Click the Validate button. The application must be able to reach the URL in order to validate
the feed

 The system automatically determines if the feed is a CAP/ATOM or RSS feed and displays
the appropriate tab

 Once the feed is validated, the Title will be displayed and the CAP Filters fields will be
enabled
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 Dictionary button - The system can replace a word with another word or phrase for this
specific feed. Refer to Dictionaries for more information

 Title - The Title is automatically filled in from the feed, but can be modified to make it more
understandable

 CAP Filters - Currently, the CAP Filters are not used

 CAP Polling Frequency - Enter the number of minutes to wait before checking for new
information in the selected feed

 CAP Repeat Frequency Until Expires - For alerts that specify an Expiration Time, enter the
number of minutes to wait to repeat the alert

 CAP Spoken Fields - Check one or more of the text fields to be converted to speech

 Queued Paging Group - Select one or more Queued Paging Groups to receive the resulting
audio.  Use CTRL-Click to select multiple Queued Paging Groups.  If the an IP Endpoint is
in more than one Queued Paging Group, it will only receive the message one time

 At least one CAP Spoken Fields and one Queued Group Name must been selected before
the Save button will be enabled

The last message from a feed can be replayed by right clicking on it on the main screen and 
selecting the Reset Feed option.  This allows for experimenting with the different CAP Spoken 
Fields to determine the best information to be spoken from a given feed 

Creating a RSS Feed 

Below is an example of creating an RSS feed for Fox News: 

 Open a web browser to http://www.foxnews.com and then scroll down to the bottom and click
on the RSS icon

 On the next page click the Subscribe button with the RSS symbol on it

 Copy the URL from the resulting page using the keyboard shortcut CTRL-C

http://www.foxnews.com/
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 Open and login to the Alert Management Configuration Console

 Click the NEW button

 Using the keyboard shortcut CTRL-V, paste the URL into the CAP/RSS Feed URL shown
below

 Click the Validate button. The application must be able to reach the URL in order to validate
the feed



TalkMasterFOCUSAutomation-AlertManagementReferenceManual 

10 

 The system automatically determines if the feed is a CAP/ATOM or RSS feed and displays
the appropriate tab

 Once the feed is validated, the Title will be displayed and the RSS options fields will be
enabled

 Dictionary button - The system can replace a word with another word or phrase for this
specific feed. Refer to Dictionaries for more information

 RSS Polling Frequency - Enter the number of minutes to wait before checking for new
information in the selected feed

 RSS Spoken Fields - Check one or more of the text fields to be converted to speech

 RSS Options -  Check the boxes to filter out XML fields from the Title and Description to
make the feed more intelligible for listeners

 Queued Paging Group - Select one or more Queued Paging Groups to receive the resulting
audio.  Use CTRL-Click to select multiple Queued Paging Groups.  If the an IP Endpoint is
in more than one Queued Paging Group, it will only receive the message one time

 At least one RSS Spoken Fields and one Queued Group Name must been selected before
the Save button will be enabled

The last message from a feed can be replayed by right clicking on it on the main screen and 
selecting the Reset Feed option.  This allows for experimenting with the different CAP Spoken 
Fields to determine the best information to be spoken from a given feed 

Dictionaries 

Text to Speak engines have a difficult time properly pronouncing certain names, cities, people, and 
other words.  In order to better pronounce words, this system has the ability to set up dictionaries that 
will be used to speak certain words more clearly or to substitute words that are more clear. 
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Dictionaries are available for ALL feeds (global), or specific feeds. 

The following example will substitute the phrase "place of work" instead of "office": 

1. Click New at the bottom left of the Edit Dictionary dialog box.
2. An entry box will show up infront of the edit dictionary window
3. Enter "Office" into the Word box
4. Enter "Place of work" in the Pronounced box

4.) Click Save. 

5.) Click Save at the bottom right of the Edit Dictionary window. 
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Menu Options 

Edit Menu 

Edit->New Feed - Opens the Create Feed dialog so a new RSS, CAP or ATOM feed can be created 

Edit->Modify Feed - Opens the Modify Feed dialog for the currently selected feed 

Edit->Delete Feed - Deletes the currently selected feed.    

Edit-> Global Dictionary - Displays a dialog where the overall dictionary for all feeds is able to be 
edited.  For more information on Dictionaries, please review the Dictionaries topic 

Edit-> Reset Feed Usage - Resets a feeds activity, and causes it to be re-processed 

Help Menu 

Help->Help on TalkMaster FOCUS Automation Alert Service Console - Opens the indexed help 
file for this application 

Help->About - Displays the version information for this application 
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Support Information 

About Us 

Digital Acoustics, LLC 

www.digitalacoustics.com 

Digital Acoustics®, TalkMaster FOCUS®, ii3®, IP7®  and UBAM®  are trademarks of Digital 
Acoustics LLC. All other marks used are properties of their respective owners. Digital Acoustics' 
product designs are packaged by leading manufacturers around the world. 

©  2007 - 2022 Digital Acoustics, LLC 

All Rights Reserved 

Contacting Technical Support 

For Information on contacting Technical Support, please visit our web site at: 

www.digitalacoustics.com 

https://www.digitalacoustics.com/
https://www.digitalacoustics.com/support
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