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TalkMaster™ FOCUS V6.0.3 - Release Notes 

September 2020 
 

TalKmaster FOCUS Server 

● Fixed an issue with multi-threading a .NET Console SDK ​API where multiple 
commands were received in the same TCP buffer, but only the last one in the 
buffer was responded to 

● Fixed an issue with sending TCP Audio to a group where the “End of Talking” 
command was not sent to devices in the group 

Admin Console 

● Fixed an issue where the ​Server-Peer port was not updated 
● Fixed an issue where the same login was used for both the Operator Console 

and the Administrator Console and notification that a previous “play file” 
command had completed 

● Fixed an issue on startup where if the "name" of the machine was longer than 20 
bytes we would crash.  Now set to 1024 like all of the other code. 
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TalkMaster FOCUS 

Release Notes 

 

TalkMaster™ FOCUS V6.0.2 - Release Notes 

March 2020 
 

TalKmaster FOCUS Server 

● Fixed an issue where an IP Endpoint could be reported as being Disconnected, 
to Consoles, but the endpoint’s LEDs indicated it was “connected”. This caused 
issues with TalkMaster communications, but SIP calls would still work 

● Improved the performance and reliability of sending RTP audio to IP Endpoints 
● Added .5 seconds of silence to the end of a pre-recorded audio file when sending 

it to one or more IP Endpoints 
● Fixed a pacing issue when sending a pre-recorded audio file via TCP to an IP 

Endpoint 
● Fixed an issue which could occur after several weeks if many devices were 

continually connecting and disconnecting  

Admin Console 

● Fixed an issue where the Text to Speech Engine on the ​Setup → File Locs​ tab 
change would not affect the selected voice 

● Added the ability to suppress Call Queue Entries generated by an IP Endpoint 
when it’s Talk button was pressed.  This enables the Talk button to trigger an 
Event in the Event Configuration Console. The new option is available on the​ IP 
Endpoints → Opt 3​ tab.  Device needs to be configured as call-button and no 
call queue entries 

● Fixed an issue where the IP Endpoint list would  be disabled when creating a 
new Paging Group on the ​Paging Groups → Endpoint Members​ tab, and the 
group type was changed to queued 

● Fixed an issue that would prevent the removal of a fixed RTP port on the ​IP 
Endpoints → Opt 1​ tab 

● Improved the performance when loading tens of thousands of entries on the 
Audit tab 

 
 

Operator Console 
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TalkMaster FOCUS 

Release Notes 

● Minor windows compatibility fixes 
● Improved Windows Message handling 

 

TalkMaster FOCUS VoIP Connect 

● Moved location of log files to a common location for both the service and the 

configuration application 

● Fixed compatibility with OnSIP when using external phone numbers 

● Minor windows compatibility fixes 
● Fixed an issue that occurred when a Paging Group was updated 

 

TalkMaster FOCUS Automation - Event Management 

● Fixed an issue where Messages that were sent to a device that was unavailable would 

play after the device was disconnected and reconnected to the Server 

● Moved location of log files to a common location for both the service and the 

configuration application 

● Minor windows compatibility fixes 
 

TalkMaster FOCUS Automation - Alert Management (RSS/CAP-Atom) 

● Moved location of log files to a common location for both the service and the 

configuration application 

● Feed ​Validate ​function works for multiple feed modifications and creation in one session 

● Minor windows compatibility fixes 
● Better text translations from HTML → spoken words 
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Release Notes 

 

TalkMaster™ FOCUS V6.0.1 - Release Notes 

December 2018 
 

TalKmaster FOCUS Server 

● Corrected a memory leak issue after a Console logoff 
● Optimized the sending of events to Consoles after the ​Update Now ​button is 

pressed in the Admin Console 
● Fixed Server crash caused when many Endpoints disconnect and reconnect  
● Reduced memory size for new threads from 1024k to 32k 
● Fixed an issue which over time could occur if many devices were continually 

connecting and disconnecting  
 
 

Admin Console 

● Corrected an issue during logon which caused a logon fail/retry loop 
 
 

Operator Console 

● Corrected a timing issue during the refreshing of Server settings that could cause 
an issue with a large number of devices 
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TalkMaster FOCUS 

Release Notes 

 

TalkMaster™ FOCUS V6.0.0 SP1 - Release Notes 

August 2018 
 

Admin Console 

● Corrected an issue where if the Admin Console ran past midnight, it would lock 
up when you tried to close it the next day 

● Corrected an issue where the number of seconds to activate an IP Endpoint’s 
Relay could not be changed from the default value of 5  

 
 

Operator Console 

● Corrected an issue where if an IP7-MZC was selected, the ​Call ​button was 
displayed instead of the ​Start ​button 

● Corrected an issue where if a new IP Endpoint connection was received, the 
device configuration would not be available for some functions 
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Release Notes 

 

TalkMaster™ FOCUS V6.0.0 - Release Notes 

July 2018 
 

TalkMaster FOCUS Server  

● Added support for changing the keep-alive time between the TalkMaster FOCUS Server 
and IP7 Endpoints with Firmware Version V7.3 or greater 

● If Paging Group audio is sent via Multicast and the Endpoints support RTP, the Server 
will send audio to the Endpoint using standard 160 byte packets (instead of 1024 byte 
UDP packets) 

● Reduced the default memory size used for creating new threads to improve overall 
memory usage 

● Optimized thread dispatching for installations with thousands of IP Endpoints  
● Added the ability to send a server based Message to a single IP Endpoint via RTP using 

the TalkMaster FOCUS .Net SDK 
● Added support for IP7 Wireless configuration 

 

Admin Console 

● Changed the meaning of the colored ICONs in the IP Endpoints tab to indicate whether 
Authorized IP Endpoints are connected to or disconnect from the TalkMaster Server 

● Added menu option ​Search-->Search IP Endpoint List​ (and keyboard shortcut ctrl+f) 
which is available on the the​ IP Endpoints​ or ​Status ​tabs 

● Added menu option ​Tools-->Remove Disconnected Devices​ to remove all IP Endpoints 
that are no longer used 

● Added the ​Endpoint Keep Alive​ value on the ​Setup-->Settings​ tab for IP Endpoints 
with firmware V7.3 or greater 

● Improved the performance of the IP Endpoints and Status tabs when connecting over 
500 IP Endpoints 

● Added support for IP7s that support a wireless network connection (available in Q3 2018) 
● For IP7-MZC Endpoints, added the ability to specify up to eight Zone Group Names.  The 

Zone Group Names are only stored by the TalkMaster FOCUS Server, not in the IP7’s 
configuration 
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TalkMaster FOCUS 

Release Notes 

Operator Console 

● Suppressed the error message “Intercom in use or not available” when a call was 
answered, but the IP Endpoint was still playing the “Your call is being connected” 
message 

● On the ​Intercoms ​tab, added support for pressing ​ctrl-f​ to search for an IP Endpoint by 
Location Name, IP Address or ICOM ID 

● Added menu option ​Search → Search IP Endpoint List​. This provides the same 
functionality as ​ctrl+f  

Firmware Management Console 

● Optimized the performance of the list box  
● Added support for pressing ​ctrl-f​ to search for an IP Endpoint by name 
● Add support for the IP7-EDx/ESx Wireless Firmware Update 
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TalkMaster™ FOCUS V5.2.6 - Release Notes 

April 2018 
 

TalkMaster Server 

● Corrected an issue with IP Endpoints configured with the Call Button option.  The “beep” 
was not playing when the Talk button was pressed 

● Added additional functionality for TalkMaster ​System Variables​ which are used to 
communicate information with ​Automation ​and ​VoIP Connect​ Consoles 

● Added support for the ​Find/Save by IP Address 

Admin Console 

● Devices currently in an active TalkMaster call or SIP call will now receive a warning 
before their configuration can be saved.  The right-click ​Reset Connection​ option should 
be used to shut down an active call.  Once the device reconnects, its configuration can 
be saved  

● Corrected an issue with menu option ​File → Import Settings​ where the settings for 
Automation​ and ​VoIP Connect​ were not imported  

● Corrected an issue that could cause an IP Endpoint configuration to be saved to the 
wrong device 

● Corrected an issue where on the IP Endpoints tab, using the cursor to quickly move 
between endpoints in the list would sometimes ask if you wanted to ​Save Changes? 

● Added menu option ​Tools → Find Device By IP Address​ for situations where the IP 
Address of an IP Endpoint is known, but the device is in a different subnet where 
multicast is not  enabled.  The TalkMaster Server must be able to contact the device via 
UDP on Port 1459 

● Added menu option ​Tools →Save Device By IP Address​ for situations where the IP 
Address of an IP Endpoint is known, but is in a different subnet where multicast is not 
enabled. The TalkMaster Server must be able to contact the device via UDP on Port 
1459 and this option must be preceded by using menu option ​Tools → Find Device By 
Address 

● Added menu option ​Tools → Record Program Events to File​ to enable the recording of 
program events and ​Tools → Open Support Folder​ to locate the resulting file 

● Added warning messages for duplicate ​Location Name​ and ​SIP Extension  
● Added ​Reset Connection​ to the IP Endpoint list right-click option 
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TalkMaster™ FOCUS V5.2.4 - Release Notes 

August 2017 
 

TalkMaster FOCUS Server  

● Added support for the new DotNet Console SDK (DAConsoleClassLibrary.dll) 
● Added the TalkMaster FOCUS Server version and run time to the beginning of each 

day’s support log 
● Removed some superfluous messages from the support log  
● Corrected an issue with sending a server based Message to a single device 
● Changed a link edit option to use more memory for 32-bit applications 
● Fixed an issue where TalkMaster Server would not recognize an RTP Port greater than 

32767 
● Call Queue entries are now created for the IP7-MZC-FD when the Handset is taken 

Off-Hook and the ​IP Endpoints → eSIP → Type​ is NOT set to ​Dial SIP Extension on 
PTT​. If the Handset is placed back On-Hook before the Call Queue entry is answered, it 
is automatically removed from the Call Queue 

 

StandAlone Firmware Management Application 

● Added USB detection code to detect insertion of Serial port 
● Prevent flashing when the Firmware is bigger than the RAM on the IP7 
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TalkMaster FOCUS 

Release Notes 

 

TalkMaster™ FOCUS V5.2.3 - Release Notes 

March 2017 
 

TalkMaster FOCUS Installer Menu 

● TalkMaster Automation and TalkMaster VoIP Connect have been removed from 
TalkMaster FOCUS Installer Menu and are available as separate Installer Menus 

● The installer Menus now run as self extracting zip files 

Admin Console 

● Corrected the “Add Device Security” menu option to accept the maximum security code 
of 16 characters 

TalkMaster FOCUS Server  

● Corrected the handling of IP Endpoint Status updates when an audio timeout had 
occurred 

● Improved memory usage by reusing memory instead of releasing and then reallocating it 
during IP Endpoint configuration 

● Corrected an issue where MZC Zone Command failures were not reported in the 
TalkMaster FOCUS Support Log 

● Corrected a timeout issue that occurred sporadically with the ii3 series 
● Corrected an issue where an IP Endpoint might not reconnect to the server correctly 
● Corrected an issue where an RTP Port might not be marked as available when a IP 

Endpoint reconnected 

TalkMaster FOCUS Firmware Management Console 

● Added protection against updating MZC Firmware with older firmware 
 

 TalkMaster FOCUS Support Central 

● Corrected an issue on very busy systems where some logging information would not be 
collected 
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TalkMaster™ FOCUS V5.2.2 - Release Notes 

November 2016 
 

Admin Console 

● Exposed the DNS Server used for the IP7’s 

eSIP DNS Lookups 

● Fixed a startup failure when no IP Endpoints 

existed 

TalkMaster FOCUS Server  

● Updated the length of the buffer used to update IP7s with V7 firmware to prevent 
possible memory corruption 

● Optimized Firmware Updating for multiple endpoints on Windows 10 and 
Windows Server 2012 

TalkMaster FOCUS Firmware Management Console 

● Corrected an issue with flashing multiple endpoints with MZC Firmware  
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TalkMaster™ FOCUS V5.2.1 SP3 - Release Notes 

September 2016 
 

TalkMaster FOCUS Server  

● Corrected the Installation to fix a Registry setting that caused the the Windows 10 
upgrade to “loose” all of the TalkMaster settings 

 

 

 

TalkMaster™ FOCUS V5.2.1 SP2 - Release Notes 

August 2016 
 

 

TalkMaster FOCUS Firmware Management Console 

● Corrected an issue where the Firmware Management Console did not always 
correctly differentiate IP7s manufactured before 2011 

 

 

TalkMaster™ FOCUS V5.2.1 SP1 - Release Notes 

July 2016 
 

TalkMaster FOCUS Server  
● Corrected an issue where ii3 intercoms could mistakenly have the “Security” 

option enabled which would prevented them from connecting to the TalkMaster 
Server 
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TalkMaster FOCUS 
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TalkMaster™ FOCUS V5.2.1 - Release Highlights 

June 2016 
 

Admin Console 

● Added support for IP7s running firmware V7. ​PLEASE NOTE​ that TalkMaster 

FOCUS V5.2.1 or greater is required for IP7 endpoints with V7 firmware 

● Added support for the new IP7-MZC Multi Zone Controller. The IP7-MZC is an IP 

Endpoint that can support up to 48 zones of full-duplex audio and is designed for 

use in Central Station security environments. Refer to the ZC tab on the IP 

Endpoints tab 

● Added the ability to display an internal "health" report on a device. Refer to the IP 

Endpoints tab 

● Added the ability to add existing MP3 audio files as Messages. Please note that 

when the audio file is sent to the IP Endpoints it will be converted to a uLaw wav 

file with an 8k sample rate 

● Added support for Paging Groups that support low priority multicast audio which 

allows the audio to be interrupted with normal priority audio or intercom requests. 

Refer to the Multicast Address and Port on the Paging Groups tab 

● Added support for using the STUN Protocol when an IP Endpoint is running as 

an eSIP client. STUN (if allowed by a firewall) can help improve connectivity 

between SIP based IP Endpoints connecting to a SIP Server from behind a 

NAT'd firewall 

● Added the ability to password protect IP Endpoints using the IP Endpoint Security 

option. IP Endpoint Security implements a Challenge Response Authentication 

process between an IP Endpoint and any software program that tries to access it. 

IP Endpoint Security requires IP7 Firmware V7.1.2 or greater. Please refer to the 

topic on Using Endpoint Security for further details 

● Added support for the new IP7-MZC - Multi Zone Controller 
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TalkMaster FOCUS 

Release Notes 

Operator Console 

● Fixed an issue where answering a call on an IP Endpoint that's TALK button was 

still engaged would cause the Operator Console to crash 

● Fixed an issue where on the first paging attempt from the Paging Groups tab, the 

“Intercom is use or not available” message was displayed 

● On the Intercoms tab, the Play File button and the Talk Mode radio buttons have 

been deprecated. They can be re-enabled in the Preferences - Layout tab, but 

users are encouraged to use the Paging Groups tab to play server based 

Messages 

● Added an option to ​Preferences - Main​ to ​Disable keyboard interface on Call 
Announce​ dialog. This prevents an operator from accidentally answering a call 

while using the keyboard when the Call Announce dialog is presented 

 

Alert Management  

● Added support for the CAP 1.2 Standard 

VoIP Connect Service 

● Many stability enhancements for the VoIP Connect Service 

TalkMaster FOCUS System Tray  

● The TalkMaster FOCUS System Tray ICON can now launch the FOCUS 
Services Status application 

 

FOCUS Services Status application  

● The FOCUS Services Status application can be used to Restart, Stop or Start 
any of the TalkMaster FOCUS Services. It can also be used to automatically 
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Release Notes 

shutdown and restart the TalkMaster FOCUS services when a laptop goes into 
and out of Suspend or Sleep mode 
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TalkMaster FOCUS 

Release Notes 

TalkMaster™ FOCUS V5.1 - Release Notes 

 
December 2016 

Important Upgrade Information 
For TMEE V4 or Earlier 

TalkMaster FOCUS Server 

● The Windows System Tray ICON used to display Server/License status has changed 

● The Windows Service name has been changed from ​Digital Acoustics TMEE Server​ to 

TalkMaster FOCUS Server​.  Please make sure any scripts that shut down/startup the service 

are updated to reflect this change  

● TMEE Server​ will be uninstalled from directory “C:\Program Files (x86)\TMEE Server“ (64-bit 

systems) or “C:\Program Files\TMEE Server“ (32-bit systems) and the ​TalkMaster FOCUS 
Service​ will be installed to directory “C:\Program Files (x86)\TalkMaster FOCUS Service” or 

“C:\Program Files\TalkMaster FOCUS Service”  

● The ​Server Storage Path​ is used to store the the daily activity and sound recordings as well as 

pre-recorded messages.  The ​Server Storage Path​ directory will ​NOT​ be altered during the 

install.  If the default directory is being used, the ​Server Storage Path​ will still point to 

“C:\Program FIles (x86)\TMEE Server” or “C:\Program FIles\TMEE Server”. If the ​Server 
Storage Path​ is to be moved to a new location: 

○ Update the ​Server Storage Path​ in ​Admin Console → Setup → File Locs 
○ Shutdown the ​TalkMaster FOCUS Server 
○ Move the existing directories (CallQueue, iArchive, MessageStore, StoredFiles, 

TempFiles) from the current ​Server Storage Path​ to the new location.  The iAudio 

directory must not be moved  

○ Start ​TalkMaster FOCUS Server 
○ Please make sure any backups are updated to reflect this change  

TalkMaster FOCUS Support Central 
● Support Central​ replaces the ​Support Console ​and the​ IP7 Support Console​. The ​Support 

Central Application​ displays ​TalkMaster FOCUS Server​ log information as well as IP7 

Tracking information  
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● The ​TalkMaster FOCUS Support Central Service​ runs as a Windows service in the 

background to capture the TalkMaster FOCUS and IP7 tracking information 

TalkMaster FOCUS Admin Console 
● The ​Admin Console​ ICON has changed 

 

TalkMaster FOCUS Operator Console 
● The ​Operator Console​ ICON has changed 

● In version 4.1 an automatic delay of the Incoming Call dialog was introduced if subsequent calls 

came in within thirty seconds of another call.  This automatic delay has been removed  

● Pressing the ​Answer Later​ button in the ​Incoming Call​ dialog used to close the ​Incoming Call 
dialog for thirty seconds. The time can now be 

set in the Preferences dialog 

● All configuration settings are automatically 

migrated 

● If a message about WMVCore.dll is 

displayed, install the Windows Feature for 

Windows Media Player 

 

TalkMaster FOCUS Firmware Management Console 

● The ​Firmware Management Console​ ICON has changed 

 

TalkMaster FOCUS Archive Viewer Console 
● The ​Archive Viewer Console​ ICON has changed 

 

TalkMaster FOCUS Text To Speech Folders 
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Release Notes 

● The ​Text To Speech Folders​ ICON has changed 

TalkMaster FOCUS VoIP Connect 

● The ​SIP Gateway Console ​will no longer be used.  Instead, the ​VoIP Connect Configuration 
Console​ will be used to assign SIP extensions to one or more IP Endpoints and the ​VoIP 
Connect Service​ will run as a background service and process the SIP calls  

● Existing SIP extensions for individual IP7 Endpoints can be converted by installing and running 

the ​SMG Console Conversion Utility from the Installation menu​.  Once installed, run the 

SMG Console Conversion Utility​ from the Windows Start menu 

● Existing SIP extensions for group extensions will ​NOT ​be converted.  The SIP extensions for 

groups of IP7s now use Server based Paging Groups.  Instead of specifying the individual IP7s 

belonging to the group:,  

○ Open the ​Admin Console  

Create ​Paging Groups​ for group extensions that were defined in the ​SMG Console​ (the 

SMG Console​ will still be available for reference) 

○ Open the ​VoIP Connect Configuration Console  
○ Select the ​Groups ​tab 

○ Double click on a Paging Group and assign the SIP extension information 

● The Windows Service ​TalkMaster FOCUS VoIP Connect Service​ will be automatically started 

when the PC is started and use the settings from the ​VoIP Connect Configuration Console  

● The ​TalkMaster FOCUS VoIP Connect Service​ must be configured to connect to the 

TalkMaster FOCUS Server using the ​VoIP Connect Service Configuration​ utility.  Supply the 

Username and Password (as defined in Admin Console → Operators) as well as the IP Address 

of the TalkMaster FOCUS Server 

● The ​SIP Gateway Console​ should no longer be used. Once all of the configuration Information 

has been converted to the ​VoIP Connect Configuration Console​, the ​SMG Console​ can be 

uninstalled and removed from the Windows Startup Folder 

● The ​SMG Console Conversion Utility​ may also be uninstalled after after the SIP extensions 

have been converted 

TalkMaster FOCUS Automation - Event Management 
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●  The ​Event Console ​has been replaced by the ​TalkMaster Event Configuration Console 

which will be used to set up new events and the ​TalkMaster Focus Event Service​ which will 

run as a background service to process the events and corresponding actions 

● Due to the additional capabilities, the existing event configuration from the ​TMEE Event 
Console​ will ​NOT ​be migrated to TalkMaster FOCUS.  The ​TalkMaster Event Configuration 
Console ​must be used to create new events (the ​TMEE Event Console​ will still be available for 

reference) 

● The Windows Service ​TalkMaster FOCUS Event Service​ will be automatically started when 

the PC is started and use the settings from the ​TalkMaster Event Configuration​.  Supply the 

Username and Password (as defined in Admin Console → Operators) as well as the IP Address 

of the ​TalkMaster FOCUS Server 
● TalkMaster FOCUS Event Service​ will be automatically started when the PC is started and use 

the settings from the ​TalkMaster Event Configuration Console  

● The ​TalkMaster FOCUS Event Service​ must be configured to connect to the TalkMaster 

FOCUS Server using the ​TalkMaster FOCUS Event Service Configuration​ utility.  Supply the 

Username and Password (as defined in Admin Console → Operators) as well as the IP Address 

of the TalkMaster FOCUS Server 

● The ​TMEE Event Console​ should no longer be used. Once all of the configuration Information 

has been converted to the ​TalkMaster Event Configuration Console​, the ​TMEE Event 
Console ​can be uninstalled and removed from the Windows Startup Folder 

 

TalkMaster FOCUS Automation - Alert Management 

● The existing configuration from the ​TMEE Alert Management Console​ is automatically 

migrated to TalkMaster FOCUS  

● The Windows Service ​Digital Acoustics Alert Management System​ will be changed to 

TalkMaster FOCUS Alert Service  
● Use the ​TalkMaster Alert Configuration Console​ to specify new RSS and CAP/ATOM feeds  

● Use the ​TalkMaster FOCUS Alert Management Service Configuration​ to verify the 

Username, Password and IP address used to connect to the TalkMaster FOCUS Server 
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